Page 1 of 2

blender 2.49rc1

Posted: Wed May 06, 2009 10:41 am
by sgefant
Hi,

blender 2.49 rc1 is available for download from http://download.blender.org/release/Ble ... .5.tar.bz2

because tbcpp was unable to build blender with mipspro in time, this build was compiled with gcc.
I guess rc2 will be built with mipspro again.

Known bugs and limitations:
* no ffmpeg
* crashes when loading files saved on 64bit platform (like linux on amd64)

To be able to use python scripts one needs to install python 2.5.x from nekoware and set the PYTHONHOME environment variable to /usr/nekoware (this is optional).

greetings,
sgefant

(edit: updated link)

EDIT: 2.49a is available, go get it here: http://www.blender.org/download/get-blender/

Re: blender 2.49rc1

Posted: Wed May 06, 2009 2:00 pm
by nekonoko
Very cool - I'll try and give it a run later this evening. Thanks much!

Re: blender 2.49rc1

Posted: Sat May 09, 2009 2:45 am
by fzalfa
./blender -w &
[1] 1525
IRIS 11# Compiled with Python version 2.5.2.
Checking for installed Python... got it!

[1] Bus error ./blender -w (core dumped)


hum hum....... won"t work on my Octane2 dual R14k....

Laurent

Re: blender 2.49rc1

Posted: Sun May 10, 2009 4:25 am
by hamei
Just downed it and unzipped, started instantly on the ol' Fool. . I don't know how to run Blender but made a couple of cubes and cones and such without problem.

The interface is weird but it does look really nice. How about a spaceball-enabled version ?

Re: blender 2.49rc1

Posted: Mon May 11, 2009 8:32 am
by nekonoko
fzalfa wrote:
./blender -w &
[1] 1525
IRIS 11# Compiled with Python version 2.5.2.
Checking for installed Python... got it!

[1] Bus error ./blender -w (core dumped)


hum hum....... won"t work on my Octane2 dual R14k....

Laurent


Same on my Tezro - can't get it to run at all.

Re: blender 2.49rc1

Posted: Mon May 11, 2009 9:49 am
by fzalfa
hi neko

i ran blender 2.49 with irix 6.5.29..... as you ?

regards

Laurent

Re: blender 2.49rc1

Posted: Mon May 11, 2009 9:55 am
by nekonoko
6.5.30 here. No problems with Blender 2.48 and a proper .B.blend file, but Blender 2.49 just cores with a bus error.

Re: blender 2.49rc1

Posted: Mon May 11, 2009 12:02 pm
by sgefant
That's strange....

I forgot to mention that the built-in .B.blend was generated on an IRIX box, so it shouldn't crash when there's no ~/.B.blend

Out of couriosity, what's the output of "ldd blender"?

Running blender through gdb might also show something of interest.

greetings,
sgefant

Re: blender 2.49rc1

Posted: Mon May 11, 2009 12:23 pm
by nekonoko

Code: Select all

 % ldd ./blender
        libGLU.so  =>    /usr/lib32/libGLU.so   
        libGL.so  =>     /usr/lib32/libGL.so   
        libXmu.so  =>    /usr/lib32/libXmu.so   
        libXext.so  =>   /usr/lib32/libXext.so 
        libXi.so  =>     /usr/lib32/libXi.so   
        libX11.so.1  =>  /usr/lib32/libX11.so.1
        libdmedia.so  =>         /usr/lib32/libdmedia.so       
        libmoviefile.so  =>      /usr/lib32/libmoviefile.so     
        libaudio.so  =>  /usr/lib32/libaudio.so
        libz.so  =>      /usr/lib32/libz.so     
        libpthread.so  =>        /usr/lib32/libpthread.so       
        libm.so  =>      /usr/lib32/libm.so     
        libc.so.1  =>    /usr/lib32/libc.so.1   
        libC.so.2  =>    /usr/lib32/libC.so.2   
        libGLcore.so  =>         /usr/lib32/libGLcore.so       
        libXsgivc.so  =>         /usr/lib32/libXsgivc.so       
        libXt.so  =>     /usr/lib32/libXt.so   
        libgen.so  =>    /usr/lib32/libgen.so   
        libmutex.so  =>  /usr/lib32/libmutex.so
        libcl.so  =>     /usr/lib32/libcl.so   
        libawareaudio.so  =>     /usr/lib32/libawareaudio.so    delay-load


I don't have gdb installed as I use MIPSpro/dbx, but I've attached the core file if that helps any.

Re: blender 2.49rc1

Posted: Mon May 11, 2009 3:46 pm
by dbx
New to blender, but old hat with Povray - anybody
use both, and can throw some comments ?
-db-

Re: blender 2.49rc1

Posted: Fri May 15, 2009 6:50 am
by nekonoko
Gave it try on my Onyx2 this morning - crashes there as well (also IRIX 6.5.30).

Code: Select all

ALERT: Process [blender] 2701 generated trap, but has signal 10 held or ignored
        epc 0x10ed3544 ra 0xace6974 badvaddr 0xfffffffffffffffd
        process has been terminated to prevent infinite loop

Re: blender 2.49rc1

Posted: Wed May 20, 2009 6:37 am
by sgefant
@nekonoko: Unfortunately I couldn't get any useful info from the coredump. I'm a bit puzzled why it doesn't work on your systems. I've tested it on an R12k Octane2 and an R10k O2 (both running Irix 6.5.30) and it seems to run ok on both.

Let's hope tbcpp can do a 2.49 build with MIPSpro and see if that one works.

greetings,
sgefant

Re: blender 2.49rc1

Posted: Wed May 20, 2009 10:34 am
by hamei
sgefant wrote: I'm a bit puzzled why it doesn't work on your systems.

Me, too. Usually if there's any crashing to be done, my computers are right there in the thick of it.

This one ran fine for me tho (Fuel, 6.5.30). Weird.

Re: blender 2.49rc1

Posted: Wed May 20, 2009 1:21 pm
by nekonoko
Well it doesn't appear to be working for fzalfa either. Unfortunately, nobody else is chiming in, so the sample size is pretty darn small.

Re: blender 2.49rc1

Posted: Wed May 20, 2009 5:03 pm
by sgefant
Is it correct that all the systems where it doesn't run are multi-processor? If that's the case, I'll revive my origin and do some tests on it.