Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

3D/2D CGI and the tools used in their creation (Maya, Photoshop, Blender, GIMP, etc.).
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
hamei
Posts: 10433
Joined: Tue Feb 24, 2004 4:10 pm
Location: over the rainbow

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby hamei » Fri Oct 24, 2008 6:41 am

oh-oh ?

Code: Select all

Compiled with Python version 2.5.2.
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
Checking for installed Python... No installed Python found.
Only built-in modules are available.  Some scripts may not run.
Continuing happily.
WARNING: core: blender: PID 13635, failed to write a  text area (core file deleted)

Have nekoware Python installed and nekoware in the path ...

sgefant
Posts: 31
Joined: Mon Jan 14, 2008 4:59 pm

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby sgefant » Fri Oct 24, 2008 7:01 am

That crash probably is not related to python. Do you have a .B.blend file in your home directory? if not, try creating one by running a older version of blender and pressing ctrl+u. If blender 2.48 works then, you've hit the same bug as I did.

User avatar
tbcpp
Posts: 271
Joined: Fri Aug 05, 2005 8:14 am
Location: Cross Plains WI

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby tbcpp » Fri Oct 24, 2008 7:40 am

From what I'm seeing on the forums, the 2.48a is hitting some issues with the regression files on other platforms as well (Linux 64 bit). I'll see what I can do about this, but it may take me awhile.

As for the Python, the nekoware python was created with some modules that Blender does not use/need so I ended up using a custom Python. What's does python -V show on your system? On the dev machine it shows "Python 2.5.2" which is the same as my custom compiled python. You may have an older version of python. I am also using Nekoware python so maybe you need to upgrade?

For those who are wondering, Blender uses the internal python but looks for the external python lib path to load all the "extra" libs like os, urlopen, etc. So you do need to have Python 2.5.2 installed on your local machine for Blender to work well with Python.
:O2000: :Octane: :O2: :O2:
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. -- Dennis Ritchie

User avatar
fzalfa
Posts: 739
Joined: Sun Jun 19, 2005 11:38 am
Location: avignon ,provence, france
Contact:

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby fzalfa » Fri Oct 24, 2008 7:57 am

and about O2 with R5000 ?

R5k is Mips IV like R1xk.... why it doesnét work on it ?

regards

Laurent
SGI or die !!!
:O2: :Octane2: :Octane: :Indigo2IMP: :Indigo2IMP: :Indigo: :Indigo: :Indy: :PI: :Crimson: :PWRSeries: :Onyx: :O2000R:
HP proliant DL 585 Quad Opteron dual core 2.5Ghz 16Gb

User avatar
hamei
Posts: 10433
Joined: Tue Feb 24, 2004 4:10 pm
Location: over the rainbow

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby hamei » Sat Oct 25, 2008 12:11 am

sgefant wrote:That crash probably is not related to python. Do you have a .B.blend file in your home directory? if not, try creating one by running a older version of blender and pressing ctrl+u. If blender 2.48 works then, you've hit the same bug as I did.


Mmm. See a .Bpib but no .B.blend.

I just downloaded and tried it out to give another data point tho. I'm not a Blender user so when it didn't start I just deleted it. Sorry :oops:

Btw, I see Python is up to 2.6 Maybe a newer version would be nice for Nekoware ?

sgefant
Posts: 31
Joined: Mon Jan 14, 2008 4:59 pm

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby sgefant » Sat Oct 25, 2008 12:18 am

fzalfa: I just tested blender on an R5k O2 and it works (as long as there is a ~/.B.blend). What is the exact error you are getting?

greetings,
sgefant

User avatar
fzalfa
Posts: 739
Joined: Sun Jun 19, 2005 11:38 am
Location: avignon ,provence, france
Contact:

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby fzalfa » Sat Oct 25, 2008 12:25 am

hi

the error is: WRONG ARCHITECTURE.......lol

Laurent
SGI or die !!!
:O2: :Octane2: :Octane: :Indigo2IMP: :Indigo2IMP: :Indigo: :Indigo: :Indy: :PI: :Crimson: :PWRSeries: :Onyx: :O2000R:
HP proliant DL 585 Quad Opteron dual core 2.5Ghz 16Gb

User avatar
UrbanHero
Posts: 298
Joined: Tue Aug 23, 2005 1:06 am
Location: Leerdam, Holland, formerly Rotterdam, Holland

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby UrbanHero » Sun Oct 26, 2008 4:18 pm

*looks at tbcpp's programming ability in awe*
-= I reject reality, and substitute my own =-

1 Indigo R3k-33 32MB XS24-Z;
1 Indy R5k-180 256MB XZ;
1 Indy R4k-175 64MB XL;
2 Indigo2 R10k-195 512MB MaxImpact;
2 Indigo2 R4k-200 256MB (XL+Extreme);
2 Octane Dual R12K-300 1024MB (MXI+V6).

yungjoon
Posts: 106
Joined: Thu Jun 03, 2004 7:53 am
Location: France

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby yungjoon » Mon Oct 27, 2008 2:23 am

Hi there,

I tested it with my Octane/R16K/2Go ram/V12 and it runs well.
I did a rendering and that was ok (test.blend). I will continue tests.

Thanks tbcpp !

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby nekonoko » Fri Nov 21, 2008 3:46 pm

Finally got around to trying this out on my Tezro today - looks great; thanks much!
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
tbcpp
Posts: 271
Joined: Fri Aug 05, 2005 8:14 am
Location: Cross Plains WI

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby tbcpp » Sun Nov 23, 2008 8:03 am

Well, my changes finally all got imported into the Blender source tree. I'm planning to pick this back up here in the next few weeks and work on getting Blender 2.5 compiled. This next version has a list of changes a mile long, so I want to make sure we get our Irix specific patches in quickly.
:O2000: :Octane: :O2: :O2:
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. -- Dennis Ritchie

strandedinnz
Posts: 258
Joined: Fri Feb 08, 2008 1:11 pm
Location: Auckland, New Zealand

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby strandedinnz » Sun Nov 23, 2008 12:08 pm

So when will the IRIX version be put up as news on the Blender site ?
How will the world know of the superhuman efforts you've put into it ?
And how will the world be turned green with envy as ye-olde SGI boxes chew through 64 threads ? ;)

Mark
:Fuel:

User avatar
tbcpp
Posts: 271
Joined: Fri Aug 05, 2005 8:14 am
Location: Cross Plains WI

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby tbcpp » Mon Nov 24, 2008 7:29 am

I sent the build into Blender today, hopefully it will get on the page soon.
:O2000: :Octane: :O2: :O2:
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. -- Dennis Ritchie

strandedinnz
Posts: 258
Joined: Fri Feb 08, 2008 1:11 pm
Location: Auckland, New Zealand

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby strandedinnz » Mon Nov 24, 2008 2:21 pm

I got around to downloading this blender version .. and it just core dumps on me :-(

Got a Fuel V10, 1gb ram and IRIX 6.5.29

I don;t have Python setup yet, but would that make a difference ?

Also what else should be installed to make it run ? There a list somewhere ?

Thanks

Mark
:Fuel:

User avatar
hamei
Posts: 10433
Joined: Tue Feb 24, 2004 4:10 pm
Location: over the rainbow

Re: Blender 2.48 - Alpha rev c - "Yafray, FFmpeg, 64 threads"

Unread postby hamei » Tue Nov 25, 2008 1:26 am

tbcpp wrote:. What's does python -V show on your system? On the dev machine it shows "Python 2.5.2" which is the same as my custom compiled python. You may have an older version of python. I am also using Nekoware python so maybe you need to upgrade?

Wow. I've been using dexter1's mirror for centuries. The newest python there is 2.4.1 Other mirrors have 2.5.2

Dex is a little behind the times :(

edit :
upped Python to 2.52
Irix 6.5.30
Fuel

Code: Select all

fewel 5% ./blender
guessing './blender' == '/usr/people/wacko/irix6/./blender'
Compiled with Python version 2.5.2.
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
Checking for installed Python... No installed Python found.
Only built-in modules are available.  Some scripts may not run.
Continuing happily.
Bus error

No .B.blend and I don't have one lying around. A placebo .B.blend makes no difference :(


Return to “SGI: Computer Graphics”

Who is online

Users browsing this forum: No registered users and 2 guests