file alteration monitor goes down

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
squeen
Moderator
Moderator
Posts: 2933
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

file alteration monitor goes down

Unread postby squeen » Thu Sep 01, 2005 4:03 am

THe file alteration monitor (fam) on the Onyx350 keeps dying. I'm running 6.5.27. There are no network mounts, just two local hard drives. I get an error message telling me either to log out or restart the machine. The SYSLOG says lots of:
Aug 29 12:13:37 3D: fam[1268]: recvmsg: Inappropriate message buffer length
Aug 29 12:13:37 4D: inetd[201145]: /usr/etc/fam: exit status 0x1

I get similar messages on an Octane2 running 6.5.27, but the fam doesn't go down as often. When the fam is down, desktop icons dissappear and fm displays no files names. This has always happened sporadically under IRIX, but the Onyx problem has become endemic. Something in the system set-up?

Any clues y'all? Very frustrating. :(

EDIT: The network connection changed recently on the machine. In general the network has been queer ever since (thanks for the "upgrade" IT!!). Almost definately related. Can fam be made less sensitive to the network?
Last edited by squeen on Thu Sep 01, 2005 5:28 am, edited 2 times in total.

User avatar
somecodemonkey
Posts: 277
Joined: Mon May 19, 2003 12:51 pm
Location: Oxford UK
Contact:

Re: file alteration monitor goes down

Unread postby somecodemonkey » Thu Sep 01, 2005 4:14 am

squeen wrote:Can fam be made less sensitive to the network?


I am guessing the "unplug it" answer isn't valid? :p
1995: Real Audio released, allowing users to listen to halting bursts of static in real time.

User avatar
squeen
Moderator
Moderator
Posts: 2933
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Thu Sep 01, 2005 4:18 am

Nope. Even a quasi-stable network is better than none. :)

I found this in /etc/fam.conf
#
# local_only makes fam ignore requests from remote clients & remote fams.
# Note that this is ignored if fam is started by inetd.
#
# The -L command-line argument overrides this option.
#
local_only = false

However, it seems that fam is most likely started by inet.d, so it's not likely to help. Now I just need to grok inetd.

Still fumbling....

User avatar
foetz
Moderator
Moderator
Posts: 6543
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Unread postby foetz » Thu Sep 01, 2005 5:06 pm

you could just turn-off fam's start within inetd. no need to disable inetd completely.
comment out:

Code: Select all

sgi_fam/1-2 stream  rpc/tcp wait/lc    root    ?/usr/etc/fam            fam

User avatar
squeen
Moderator
Moderator
Posts: 2933
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Fri Sep 02, 2005 3:43 am

Hi foetz!

What I have done is add the -L option to the end of the inetd.conf line hoping that would do the trick---we'll see.

However, if I take inetd out of the loop, any suggestions on where to start fam from? rc2.d script?

Thanks for the reply.

User avatar
foetz
Moderator
Moderator
Posts: 6543
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Unread postby foetz » Sat Sep 03, 2005 4:14 pm

squeen wrote:Hi foetz!

What I have done is add the -L option to the end of the inetd.conf line hoping that would do the trick---we'll see.

However, if I take inetd out of the loop, any suggestions on where to start fam from? rc2.d script?

Thanks for the reply.


sure, rc2.d should be fine.
why do you think after stating it outside inetd it will be better?

User avatar
squeen
Moderator
Moderator
Posts: 2933
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Mon Sep 05, 2005 8:36 am

foetz wrote:why do you think after stating it outside inetd it will be better?


From the fam man page
-L Local-only mode. fam will only accept requests
from clients running on the local machine.
This overrides the local_only flag in the
configuration file. This option is ignored if
fam is started by inetd.


It isn't really clear which option is ignored, local_only, -L or both. I'm hoping by adding the -L option in inetd.conf I will circumvent this, but if it doesn't, I have another method to try. BTW, (crossing fingers) so far so good.

User avatar
squeen
Moderator
Moderator
Posts: 2933
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Tue Sep 06, 2005 10:02 am

Just went doen again. Got this message
sgI_fam/tcp server failing (looping), service terminated. Use -R to increase maximum rate if this is...


The help says
Server Failing (looping); Service Terminated



This message indicates that the inetd (Internet super-server) daemon received too many requests for a specific service. By default inetd limits this to 1000 connections every 60 seconds.

This message may occur due to any of the following reasons:

Too many service requests occurred in a short interval.

A broken client program is requesting a service too often.

A malicious user is running a program that is flooding the server with too many requests, to deny service to other users.

The invoked service program has an error causing clients to retry their requests for services too quickly.

If only the first problem exists, you may use inetd's -R option to increase the rate limit (see man inetd for more information.)

If the problem persists, contact your System Administrator or your service provider.

For information on how to configure or disable System Alerts, click here

User avatar
squeen
Moderator
Moderator
Posts: 2933
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Tue Sep 06, 2005 10:05 am

From the syslog

Code: Select all

Sep  6 12:58:23 3D:eno fam[41465874]: Warning!  Started by inetd, so -L (local_only) option is being ignored!
Sep  6 12:58:23 3D:eno fam[41465874]: sendmsg: Inappropriate message buffer length
Sep  6 12:58:23 3D:eno fam[41381761]: recvmsg: Inappropriate message buffer length
Sep  6 12:58:23 4D:eno inetd[41428585]: /usr/etc/fam: exit status 0x1

User avatar
foetz
Moderator
Moderator
Posts: 6543
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Unread postby foetz » Wed Sep 07, 2005 5:38 pm

squeen wrote:From the syslog

Code: Select all

Sep  6 12:58:23 3D:eno fam[41465874]: Warning!  Started by inetd, so -L (local_only) option is being ignored!
Sep  6 12:58:23 3D:eno fam[41465874]: sendmsg: Inappropriate message buffer length
Sep  6 12:58:23 3D:eno fam[41381761]: recvmsg: Inappropriate message buffer length
Sep  6 12:58:23 4D:eno inetd[41428585]: /usr/etc/fam: exit status 0x1


okay, so did you start it by hand?


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 2 guests