IRIX netinstall via DINA - getting invalid argument error.

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
paulfred
Posts: 107
Joined: Thu May 22, 2008 5:01 am

IRIX netinstall via DINA - getting invalid argument error.

Unread postby paulfred » Mon Sep 11, 2017 5:35 am

I've been trying to get my Octane to netboot my IRIX installation tools for some time now to no avail and I feel pretty stuck right now.

As for the network environment: My main VM machine is running DINA, I've confirmed successful TFTP transfers with other computers in the network. I'm also able to load fx on the Octane via

Code: Select all

boot - f bootp()192.168.1.100:/irix/65inst/stand/fx.64

Everything good up to here. However, as soon as I try to boot the install tools from the PROM menu (host 192.168.1.100, directory is /irix/65inst/dist) I'm greeted with

Code: Select all

Setting $netaddr to 192.168.1.101 (from server)
Cannot invoke addr 0.
Cannot load xio(0)pci(15)multi(0)network(0)bootp()192.168.1.100:/irix/65inst/dist/sa(sash64) - - invalid argument.


I'm able to successfully transfer the sa file that the Octane requests to any other TFTP client, I checked with PumpKIN on Windows and tftp on OS X. Any hints about this behaviour?
:Fuel: :Octane: :O2: :1600SW:
Apple Mac Pro 1,1, IBM p275, IBM p285, IBM 43p140, Sun Fire 280R, HP C8000, Fujitsu Primepower 250, HP rx4640

User avatar
uunix
Donor
Donor
Posts: 1808
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Re: IRIX netinstall via DINA - getting invalid argument error.

Unread postby uunix » Mon Sep 11, 2017 5:43 am

paulfred wrote:I've been trying to get my Octane to netboot my IRIX installation tools for some time now to no avail and I feel pretty stuck right now.

As for the network environment: My main VM machine is running DINA, I've confirmed successful TFTP transfers with other computers in the network. I'm also able to load fx on the Octane via

Code: Select all

boot - f bootp()192.168.1.100:/irix/65inst/stand/fx.64

Everything good up to here. However, as soon as I try to boot the install tools from the PROM menu (host 192.168.1.100, directory is /irix/65inst/dist) I'm greeted with

Code: Select all

Setting $netaddr to 192.168.1.101 (from server)
Cannot invoke addr 0.
Cannot load xio(0)pci(15)multi(0)network(0)bootp()192.168.1.100:/irix/65inst/dist/sa(sash64) - - invalid argument.


I'm able to successfully transfer the sa file that the Octane requests to any other TFTP client, I checked with PumpKIN on Windows and tftp on OS X. Any hints about this behaviour?

I don't use DINA, but from the clients perspective, I would imagine it is the same.
You can boot to fx, looking at that though you are missing --x at the end, so it may be read only, but that's a side note.
When you click install from the boot tools screen on the Octane and after you have fx'd if you wish), I would select remote and then it's pretty straight forward? It asks your for server and then the path to dist from the install tools CD or in your repository, how ever it is set up?

Are you running a second command from the prom to run the install?

Ignore that, I can see you are clicking the install button.

[Edit] Last time I had an issue similar, was bad media.
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------

paulfred
Posts: 107
Joined: Thu May 22, 2008 5:01 am

Re: IRIX netinstall via DINA - getting invalid argument error.

Unread postby paulfred » Mon Sep 11, 2017 7:37 am

Your "bad media" hint was spot on! It seems some files didn't get properly copied from my NAS to the DINA VM, so the poor TFTP server worked as intended but sent some corrupt files over to the Octane.
:Fuel: :Octane: :O2: :1600SW:
Apple Mac Pro 1,1, IBM p275, IBM p285, IBM 43p140, Sun Fire 280R, HP C8000, Fujitsu Primepower 250, HP rx4640

User avatar
dexter1
Moderator
Moderator
Posts: 2743
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: IRIX netinstall via DINA - getting invalid argument error.

Unread postby dexter1 » Mon Sep 11, 2017 10:57 am

Can you try substituting the server ip address 192.168.1.100 with it's machine name when attempting a network installation?

fx only uses tftp and bootp services, but sa and miniroot have more demands, like rsh, a working ksh and a server who is identifiable by name, not by ip address, at least according to my assessment.


Kudos to Uunix :) Glad that you got it working
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest