Problems installing/running IRIX on a Fuel

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Thu Jun 30, 2016 1:14 am

Ok, I will try this today evening.

I also wanted to look what comes out of the serial port. What are the settings for it?

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Thu Jun 30, 2016 9:04 am

I tried, but neither does running diagnostic works (because the PROM want to load it from the harddisk) nor exist there a diagnostic program in the stand folder of the CD.

So how can I proceed?

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Thu Jun 30, 2016 11:06 am

I got the messages from the serial out and now I know that I definitely got a SCSI problem.

Most of the time the CD drive is recognized, but sometimes not?!

My hard disk is recognized every time, but there seems to be a problem with the bus, because the PROM finds 14 devices?!

Any tips? Hints?

User avatar
japes
Donor
Donor
Posts: 1006
Joined: Thu Nov 08, 2007 4:35 pm
Location: Lynnwood, WA

Re: Problems installing/running IRIX on a Fuel

Unread postby japes » Thu Jun 30, 2016 11:14 am

Try another optical drive if you have one handy. Or at least disconnect the one you have and see if you get more consistent scsi bus enumeration.

I don't remember if the terminators are molded on the cables for the Fuel. Check those. I also don't remember if it has a single cable for the optical drives and hard drives. Unfortunately the cable that reaches the hard drives is uncommon so hopefully it's in servicable condition.
:O3000: :Fuel: :Tezro: :Tezro: :Octane2: :Octane: :Octane: :Indigo: :Indigo: :Indigo: :Indigo: :O2: :1600SW: :O2: :1600SW: :1600SW: :Indigo2: :Indigo2: :Indigo2: :Indigo2: :Indigo2IMP: :Indy: :Indy: :Indy: :Indy: :O3x0: :O3x02L: :O3x02L:

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Thu Jun 30, 2016 12:51 pm

As I wanted to change the SCSI cable I saw that the cable was not fully inserted, must happened when I changed the disk. So now SCSI is fine and I did another installation run. Everything went fine till 94%. It stood there again for over 30mins and I pushed the power button and it instantly went on.

But same problem again, after installation finished and the Fuel rebooted, it hangs on booting IRIX :(

I also can´t run the diagnostic program because I get the following error "Autoboot failed. dksc(0,1,0):/stand/smdk/smdk: no such file or directory.".

What could I do next? Would the output of the L1 be helpful?

Edit::

Could it be a problem that the NVRAM battery is dead?

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Thu Jun 30, 2016 2:07 pm

So I changed the CD drive also and changed the hard disk back to the original one and everything seemed fine. No SCSI problems.

I started another installation and this time it hang by 37%. At the moment I would guess that it is the SCSI bus, but how could it be that this works sometimes, sometimes not and sometimes there are no errors but it wont work when installing?

User avatar
japes
Donor
Donor
Posts: 1006
Joined: Thu Nov 08, 2007 4:35 pm
Location: Lynnwood, WA

Re: Problems installing/running IRIX on a Fuel

Unread postby japes » Thu Jun 30, 2016 2:18 pm

I walk away from IRIX installs usually, and haven't installed from discs in longer than I remember. Any chance you can try installing from the network? It's easy with another IRIX machine, but should be easy from DINA if you have infrastructure to support the VM.

At 94% I would imagine we're into running the post-install scripts. If it was still reading from the discs I'd ask if the disc was clean and reading okay in your drive, except I think you'd get an error after a few minutes and would probably have said the drive light keeps flashing.

I wonder if there's a script that isn't playing well with your hardware. I'd try a different version of overlays if you have them available.

EDIT: written before previous post.
:O3000: :Fuel: :Tezro: :Tezro: :Octane2: :Octane: :Octane: :Indigo: :Indigo: :Indigo: :Indigo: :O2: :1600SW: :O2: :1600SW: :1600SW: :Indigo2: :Indigo2: :Indigo2: :Indigo2: :Indigo2IMP: :Indy: :Indy: :Indy: :Indy: :O3x0: :O3x02L: :O3x02L:

User avatar
japes
Donor
Donor
Posts: 1006
Joined: Thu Nov 08, 2007 4:35 pm
Location: Lynnwood, WA

Re: Problems installing/running IRIX on a Fuel

Unread postby japes » Thu Jun 30, 2016 2:20 pm

Seems your Fuel is very cranky. Might be the SCSI cable. There was a post a long while back where someone had strange problems and they resolved when a new cable was installed.

You might also have power problems and the drives are going offline. Do you have any extra memory you can remove? Add-in cards you can remove?
:O3000: :Fuel: :Tezro: :Tezro: :Octane2: :Octane: :Octane: :Indigo: :Indigo: :Indigo: :Indigo: :O2: :1600SW: :O2: :1600SW: :1600SW: :Indigo2: :Indigo2: :Indigo2: :Indigo2: :Indigo2IMP: :Indy: :Indy: :Indy: :Indy: :O3x0: :O3x02L: :O3x02L:

User avatar
uunix
Donor
Donor
Posts: 1808
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Re: Problems installing/running IRIX on a Fuel

Unread postby uunix » Thu Jun 30, 2016 4:38 pm

I had a dodgy CD not long ago, it was nice and shiny so I thought I'd use that instead of my normal 6.5.7 disk and caused all sorts of strange behaviour. IIRC I was installing on an INDY. Reverting back to normal disks, all worked fine.

Saying that, if your NVRAM is dead, you may want to power up, set certain settings using the PROM and restart install without powering off. Unsure what you need to set, but I suspect EADDR etc.. I could post my 'nvram -v' from my FUEL for you to copy some settings if you like (I'm going on holiday tomorrow lunchtime, so If I cannot do it maybe someone else would).

What does your 'printenv' display at the PROM?
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Thu Jun 30, 2016 9:40 pm

I can post my PROM env later today, but it looked good.

I changed my CDs for the last install, but can try once more with the other CDs. Also I will try to remove half of the memory and change the cable for the CD drive. Does I need a terminator on this cable? Because there isn´t one and I´m not sure I had a terminator in any computer on the CD side. But then it would not work w/o the terminator, would it?

Is there a guide how to install DINA and how to install IRIX over network?

User avatar
japes
Donor
Donor
Posts: 1006
Joined: Thu Nov 08, 2007 4:35 pm
Location: Lynnwood, WA

Re: Problems installing/running IRIX on a Fuel

Unread postby japes » Fri Jul 01, 2016 2:03 am

FlasBurn wrote:Is there a guide how to install DINA and how to install IRIX over network?


If you search the forums there should be a thread or two. I just checked the wiki though and found this article: http://www.nekochan.net/wiki/Using_DINA ... on_of_IRIX
:O3000: :Fuel: :Tezro: :Tezro: :Octane2: :Octane: :Octane: :Indigo: :Indigo: :Indigo: :Indigo: :O2: :1600SW: :O2: :1600SW: :1600SW: :Indigo2: :Indigo2: :Indigo2: :Indigo2: :Indigo2IMP: :Indy: :Indy: :Indy: :Indy: :O3x0: :O3x02L: :O3x02L:

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Fri Jul 01, 2016 12:43 pm

I tried to use DINA, but as I´m not even getting the keyboard changed to us I gave up (who uses this kind of crap like vi ;) ).

So I will try to setup a linux server for it, but this will take a while :(

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Fri Jul 01, 2016 3:04 pm

I got IRIX installed and running :D

I still don´t know what of all the changes did it, but I will find out.

This time I changed the cd drive, the position of the hard disk on the scsi cable and I did install the maintenance and the feature stream.

User avatar
dexter1
Moderator
Moderator
Posts: 2743
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: Problems installing/running IRIX on a Fuel

Unread postby dexter1 » Fri Jul 01, 2016 3:21 pm

Well done! You can check which IRIX stream you're on by issuing 'uname -aR' : it should report either 6.5.22m or 6.5.22f
I don't think you can install both the maintenance and feature stream at the same time since you have to choose one during inst.

It was probably a combination of a doubly assigned SCSI id and/or a bad flatcable connector that made the first installs go wrong.
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:

FlasBurn
Posts: 98
Joined: Mon May 19, 2014 10:01 pm
Location: Germany

Re: Problems installing/running IRIX on a Fuel

Unread postby FlasBurn » Sat Jul 02, 2016 12:46 am

There is nothing I can do wrong with the SCSI ids as the hard disk and the cd drive are on different SCSI busses. But what seems to be a problem (and explains the problems) is the SCSI cable connector, but as I will be getting some new cables next week (and some new hard disks ;) ) I will know more then.

Now I just have to get the internet working ;)


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: Ahrefs [Bot], Bing [Bot], Yahoo [Bot] and 1 guest