IRIX 6.5.x installation problems

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
josehill
Moderator
Moderator
Posts: 3303
Joined: Mon Jun 06, 2005 9:53 pm
Location: New England, USA
Contact:

Re: IRIX 6.5.x installation problems

Unread postby josehill » Sun May 18, 2014 4:18 pm

nongrato wrote:i've seen on YouTube a lot of videos of IRIX demos, but they seem to be absent in my IRIX distribution, at least i'm unable to find them anywhere- the toolchest item "find-> demos" is greyed out and there is no "demos" tab in the icon catalog. Where do people get them? Should they be purchased separately?


Some models, such as O2s, Octanes, and Onyx2s, shipped with machine-specific demo CDs, but those discs technically were not part of the "standard" IRIX distribution. Another source of demonstration/trial software were SGI's "Hot Mix" CDs, which were released regularly to support contract customers.

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Tue May 20, 2014 4:26 am

yes, but what about those 3D demos and "buttonfly" menu? Where are they found?

Image
:Octane2: :320:

User avatar
duck
Donor
Donor
Posts: 727
Joined: Mon Oct 27, 2003 5:22 pm
Location: Jakobstad, Finland
Contact:

Re: IRIX 6.5.x installation problems

Unread postby duck » Tue May 20, 2014 6:13 am

The package is named "demos" and installs to /usr/demos, I got mine from the Applications, June 1998 CD.
:Octane: halo, octane Image knightrider, d i g i t a l AlphaPC164, pond, soekris net6501, misc cool stuff in a rack
N.B.: I tend to talk out of my ass. Do not take it too seriously.

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Tue May 20, 2014 7:33 am

Probably my "Apps" CD is "too new". Demos package is absent there :(

Image
:Octane2: :320:

User avatar
jan-jaap
Donor
Donor
Posts: 4881
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands
Contact:

Re: IRIX 6.5.x installation problems

Unread postby jan-jaap » Tue May 20, 2014 7:49 am

Yes, you need the applications disc from the original (6/98) IRIX 6.5 release.

After that, the demos were removed from the applications disc and put on separate discs (General & Platform Demos 6.5.x, or various system specific demo discs)
:PI: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indigo2: :Indigo2: :Indigo2IMP: :Octane: :Octane2: :O2: :O2+: Image :Fuel: :Tezro: :4D70G: :Skywriter: :PWRSeries: :Crimson: :ChallengeL: :Onyx: :O200: :Onyx2: :O3x02L:
To accentuate the special identity of the IRIS 4D/70, Silicon Graphics' designers selected a new color palette. The machine's coating blends dark grey, raspberry and beige colors into a pleasing harmony. (IRIS 4D/70 Superworkstation Technical Report)

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Tue May 20, 2014 9:51 am

oh, well.. i'll keep looking for a proper CD.
:Octane2: :320:

Pontus
Posts: 695
Joined: Thu May 08, 2008 12:12 pm
Location: Uppsala, Sweden

Installing 6.5.22 on Indigo. Conflict issue

Unread postby Pontus » Thu Jan 28, 2016 2:43 pm

Hi

I'm trying to install 6.5.22 from scratch on my trusty old Indigo (it has been running 5.3). And I'm following Ian's guide: http://www.futuretech.blinkenlights.nl/6.5inst.html

I'm using the following CDs that I read in before typing "go"

IRIX 6.5.22 Overlays [1 of 3] November 2003 <-- I'm booting the install from this one
IRIX 6.5 Foundation 1
IRIX 6.5 Foundation 2
IRIX 6.5 Applications November 2003
IRIX 6.5.22 Overlays [2 of 3] November 2003
IRIX 6.5.22 Overlays [3 of 3] November 2003

I get conflicts with inventor_dev.sw.base, it requires some development library. And I get a conflict with java plugin for mozilla.

Not sure what the best way to resolve the conflicts are or which CDs I need for the requirements of those packages.

What am I doing "wrong"?


If it helps. I chose to install a feature stream.

I'm now trying to follow this: https://www.youtube.com/watch?v=RsfDH3yM6nw

which suggest:

keep java2_plugin.sw32.mozilla_freeware
keep inventor_dev.sw.base
keep inventor_dev.sw.lib

But have a sneaking suspicion that I'm just ducking for future problems.
Last edited by foetz on Thu Jan 28, 2016 5:18 pm, edited 1 time in total.
Reason: merged
:Onyx2R: :IRIS3130: :Crimson: :4D310: :Onyx2: :O2000: :O200: :PI: :Fuel: :Indigo: :Octane: :O2: :Indigo2IMP: :Indigo2: :Indy: :1600SW: :320: :pdp8e:
:BA213: <- MicroVAX 3500 :BA213: <- DECsystem 5500 :BA215: <- MicroVAX 3300
Pictures of my collection: www.pdp8.se

User avatar
uunix
Donor
Donor
Posts: 1793
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Re: Installing 6.5.22 on Indigo. Conflict issue

Unread postby uunix » Thu Jan 28, 2016 3:40 pm

I think I tend to not install them at the time.

Conflicts 1a to all of em..

Certainly the java ones.
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: IRIX 6.5.x installation problems

Unread postby foetz » Thu Jan 28, 2016 5:27 pm


Pontus
Posts: 695
Joined: Thu May 08, 2008 12:12 pm
Location: Uppsala, Sweden

Re: IRIX 6.5.x installation problems

Unread postby Pontus » Thu Jan 28, 2016 11:41 pm

Thank you. I gave up last night. For some reason, fx decided 50MB was enough for /root :) Easy to fix but I went to bed instead.

From what I've read here and in other sources, "conflicts 1a 2a" is the way to go and fix any issues later.

One question remains though, which Applications CD(s) to use?

Most seem to suggest that you use the "Applications CD" that matches the version you install, in my case "November 2003". But the demos are on the original "June 1998". Can I read in both? And should I read in "Supplementary Applications" ?
:Onyx2R: :IRIS3130: :Crimson: :4D310: :Onyx2: :O2000: :O200: :PI: :Fuel: :Indigo: :Octane: :O2: :Indigo2IMP: :Indigo2: :Indy: :1600SW: :320: :pdp8e:
:BA213: <- MicroVAX 3500 :BA213: <- DECsystem 5500 :BA215: <- MicroVAX 3300
Pictures of my collection: www.pdp8.se

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: IRIX 6.5.x installation problems

Unread postby foetz » Fri Jan 29, 2016 11:06 am

Pontus wrote:But the demos are on the original "June 1998". Can I read in both? And should I read in "Supplementary Applications" ?

that's something you can try later, once it's installed. in most cases it's a good idea to do a rather minimal installation and take care of everything else later from within irix using swmgr

SAQ
Posts: 5871
Joined: Wed Jul 19, 2006 8:37 am
Location: Renton, WA

Re: IRIX 6.5.x installation problems

Unread postby SAQ » Fri Apr 01, 2016 6:37 am

Supplementary Applications can create a system that you don't expect - it removes Impressario and installs a demo version of ESP PrintPro (which was the $$ version of CUPS). There's also CDE on there, and an older version of OpenOffice 1.x (probably the most useful part).

My advice - ignore unless you know you want it.

I'd install with the overlay version of apps, then add what you know you want from the 1998 disk (demos). Don't do a blanket install, b/c you can get a whole bunch of outdated servers.
"Brakes??? What Brakes???"

"I am O SH-- the Great and Powerful"

:Indigo: :Octane: :Indigo2: :Indigo2IMP: :Indy: :PI: :O3x0: :ChallengeL: :O2000R: (single-CM)


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 3 guests