IRIX 6.5.x installation problems

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

IRIX 6.5.x installation problems

Unread postby nongrato » Thu May 15, 2014 6:51 am

Hi, everyone!

Sorry if i'm posting to a wrong board - i'm new to this forum, and new to SGI machines. I'm trying to install IRIX.6.5.x on Octane(R12000 400Mz, 1Gb ram, MXI). Funny, but the huge chassis of Octane has no room for internal CDROM, so network install is the only option at the moment.

what i have:

2 "IRIX Foundations" Cds, 3 "Install tools and overlays" CDs.

What i do:

since a standard PC cdroms are unable to read IRIX media, i had to create images using "dd", then mount then and copy the content of all CDs into one directory. The boopt server on my debian box seems to work fine- i'm able to load fx and start installer with no problem. The installation process also gives me no errors, except for several conflicts, but they do not seem fatal to me. It complains about missing some prerequisites for netscape plugins or something. Troubles begin when i restart the system- the startup process always ends up with a kernel panic.

Image

I tried different distributions from 6.5.11 to 6.5.30 with a same luck. I mean no luck at all. All I can do is to boot in a single user mode.

I'm totally at a loss now, probaly someone could point me a direction? What am I missing or doing wrong?
:Octane2: :320:

User avatar
duck
Donor
Donor
Posts: 746
Joined: Mon Oct 27, 2003 5:22 pm
Location: Jakobstad, Finland
Contact:

Re: IRIX 6.5.x installation problems

Unread postby duck » Thu May 15, 2014 7:02 am

Looks to me like you're doing it right. You may have faulty hardware, perhaps you could try the extended test in the PROM.
:Octane: halo, octane Image knightrider, d i g i t a l AlphaPC164, pond, soekris net6501, misc cool stuff in a rack
N.B.: I tend to talk out of my ass. Do not take it too seriously.

User avatar
Trippynet
Donor
Donor
Posts: 813
Joined: Thu Aug 15, 2013 6:22 am
Location: Aberdeen, Scotland, UK

Re: IRIX 6.5.x installation problems

Unread postby Trippynet » Thu May 15, 2014 7:32 am

Might be worth trying DINA. This is useful for isntalling IRIX over a network.

Edit: Link is here: http://dina.harrydebug.com/
Systems in use:
:Indigo2IMP: - Nitrogen: R10000 195MHz CPU, 384MB RAM, SolidIMPACT Graphics, 36GB 15k HDD & 300GB 10k HDD, 100Mb/s NIC, New/quiet fans, IRIX 6.5.22
:Fuel: - Lithium: R14000 600MHz CPU, 4GB RAM, V10 Graphics, 72GB 15k HDD & 300GB 10k HDD, 1Gb/s NIC, New/quiet fans, IRIX 6.5.30
Other system in storage: :O2: R5000 200MHz, 224MB RAM, 72GB 15k HDD, PSU fan mod, IRIX 6.5.30

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Thu May 15, 2014 7:52 am

duck wrote:You may have faulty hardware, perhaps you could try the extended test in the PROM.


well, this could be a HW failure, but i got this machine with a working system installed. "kind of working" - looks like a sys admin who maintained this machine did everything to make the system impossible for normal use: the toolchest was a mess, a lot of features were locked or removed, the system did not save workspace settings etc. I still have a backup image for any case, but i want a fresh system.

How do i run those extended tests? is it "Run diagnostics" in the PROM main menu? I did it several times, it says "tests completed". How can i see a detailed output?

Trippynet wrote:Might be worth trying DINA. This is useful for isntalling IRIX over a network.

Edit: Link is here: http://dina.harrydebug.com/


thanks! that definately looks worth trying!
:Octane2: :320:

User avatar
duck
Donor
Donor
Posts: 746
Joined: Mon Oct 27, 2003 5:22 pm
Location: Jakobstad, Finland
Contact:

Re: IRIX 6.5.x installation problems

Unread postby duck » Fri May 16, 2014 6:27 am

nongrato wrote:
duck wrote:You may have faulty hardware, perhaps you could try the extended test in the PROM.


well, this could be a HW failure, but i got this machine with a working system installed. "kind of working" - looks like a sys admin who maintained this machine did everything to make the system impossible for normal use: the toolchest was a mess, a lot of features were locked or removed, the system did not save workspace settings etc. I still have a backup image for any case, but i want a fresh system.

How do i run those extended tests? is it "Run diagnostics" in the PROM main menu? I did it several times, it says "tests completed". How can i see a detailed output?


Sorry for being unclear, that was what I meant.

Searching for cause 0x8<CE on the forum yields some posts though: first hit with a link to this thread which suggests a graphics board issue.

If you have a serial console or cable, you could try to boot up without the graphics.
:Octane: halo, octane Image knightrider, d i g i t a l AlphaPC164, pond, soekris net6501, misc cool stuff in a rack
N.B.: I tend to talk out of my ass. Do not take it too seriously.

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Fri May 16, 2014 9:10 am

wow..

i dunno what happenned.. i removed the graphics board, disassembled it, replaced the thermal grease on every chip, reseated TRAM modules, and reinstalled the system again.. and.. that worked! now i have a new shiny IRIX!

thank you, Staffan! your help is highly appreciated!
:Octane2: :320:

User avatar
duck
Donor
Donor
Posts: 746
Joined: Mon Oct 27, 2003 5:22 pm
Location: Jakobstad, Finland
Contact:

Re: IRIX 6.5.x installation problems

Unread postby duck » Fri May 16, 2014 10:32 am

nongrato wrote:wow..

i dunno what happenned.. i removed the graphics board, disassembled it, replaced the thermal grease on every chip, reseated TRAM modules, and reinstalled the system again.. and.. that worked! now i have a new shiny IRIX!

thank you, Staffan! your help is highly appreciated!


Wow, that sounds a bit extreme, just reseating may well have fixed it. I'm happy you got it to work though!
:Octane: halo, octane Image knightrider, d i g i t a l AlphaPC164, pond, soekris net6501, misc cool stuff in a rack
N.B.: I tend to talk out of my ass. Do not take it too seriously.

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Sat May 17, 2014 6:01 am

don't worry, i like disassembling stuff, fortunately in most cases i can put everything back :)

alright, this problem is solved, but my exploration of IRIX OS has just begun, i'll be back soon with more noob questions :)
:Octane2: :320:

User avatar
guardian452
Donor
Donor
Posts: 3467
Joined: Tue Aug 21, 2007 10:12 pm
Location: United States
Contact:

Re: IRIX 6.5.x installation problems

Unread postby guardian452 » Sat May 17, 2014 7:37 am

I remember having to reflow a bunch of pins on my MXI tram asics, filed down the mounting bosses for the heatsinks (they are designed to work with a thermal pad/shim) and lubed them up with thermal grease.. good times :)

After a while the thermal shims break down and the chips get so hot the pins lift off their solder pads. You'll know there's a problem when textured output looks really bad, but it can cause other graphics artifacts, too.

viewtopic.php?f=3&t=16718092

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Sat May 17, 2014 8:56 am

Btw, what is the normal working temperature of sgi graphics boards? Assuming they have no active cooling it should not be that high?
:Octane2: :320:

robespierre
Posts: 1579
Joined: Mon Sep 12, 2011 2:28 pm
Location: Boston

Re: IRIX 6.5.x installation problems

Unread postby robespierre » Sat May 17, 2014 9:49 am

You'd have to measure it carefully using thermocouples, but IMPACT does get hot to the touch, maybe 150°F (66°C). There are icons printed on the boards that warn of the possibility they could burn you.
:PI: :O2: :Indigo2IMP: :Indigo2IMP:

User avatar
guardian452
Donor
Donor
Posts: 3467
Joined: Tue Aug 21, 2007 10:12 pm
Location: United States
Contact:

Re: IRIX 6.5.x installation problems

Unread postby guardian452 » Sat May 17, 2014 4:38 pm

Octane graphics boards have a hurricane of air flowing over them especially in slot A and B... D is the worst and will force fastfan on. Not sure what you mean by 'no active cooling'. Are your fans working? The big one on the bottom is most important, but you should also feel air sucked in the lower front grille (the frontplane) and the top rear fan (the hdds)

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Sat May 17, 2014 5:34 pm

yeah, all fans function ok, otherwise i 'd already had a pile of ash instead of my Octane :) btw, do i need to keep the door on the faceplate open when machine is running?
:Octane2: :320:

SAQ
Posts: 5871
Joined: Wed Jul 19, 2006 8:37 am
Location: Renton, WA

Re: IRIX 6.5.x installation problems

Unread postby SAQ » Sun May 18, 2014 1:02 pm

nongrato wrote:yeah, all fans function ok, otherwise i 'd already had a pile of ash instead of my Octane :) btw, do i need to keep the door on the faceplate open when machine is running?


No, that can be open or closed. SGIs are designed to be run with the covers/skins on, so don't run them with bits removed (Indigo2 needs the 5-1/4" drive bay installed as well otherwise air won't flow properly over the CPU), but the doors can be open or closed.
"Brakes??? What Brakes???"

"I am O SH-- the Great and Powerful"

:Indigo: :Octane: :Indigo2: :Indigo2IMP: :Indy: :PI: :O3x0: :ChallengeL: :O2000R: (single-CM)

User avatar
nongrato
Posts: 215
Joined: Thu May 15, 2014 5:24 am
Location: SPb, RU
Contact:

Re: IRIX 6.5.x installation problems

Unread postby nongrato » Sun May 18, 2014 3:21 pm

this thread eventually turned into "newcomer's noob questions". :D

alright, another one:

i've seen on YouTube a lot of videos of IRIX demos, but they seem to be absent in my IRIX distribution, at least i'm unable to find them anywhere- the toolchest item "find-> demos" is greyed out and there is no "demos" tab in the icon catalog. Where do people get them? Should they be purchased separately?
:Octane2: :320:


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 1 guest