IRIX 6.5.30 Awful Application Instability

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
iffy50
Posts: 43
Joined: Sun Jan 23, 2011 2:45 pm
Location: Bonn, Germany

IRIX 6.5.30 Awful Application Instability

Unread postby iffy50 » Fri Apr 22, 2011 3:30 am

Hi,

I'm having some pretty bad problems with instability in applications under 6.5.30 on my Octane(2) - Dual 300Mhx V12 DCD 1.75gb. The nekoware Seamonkey and Firefoxes (latest versions off nekoware) will just crash when I try and open a google search for example (single tab, just booted and opened up the search window. The apps just crash and dissapear. But the one thing that's really annoying me is when the montior gets turned off for power saving, I can't wake it up again (keyboard, mouse don't wake it). The machine still responds to telnet, it just won't wake up.

The most annoying thing is that it's just been rendering all night and I can't get the damn image off it :-(

I've done a lot of upgrading since I originally installed it (new IP board, new Xbow 1.4, new graphics, new memory - still the same case :-)). Do I need to do a fresh IRIX install, or is there anything else that I can try? Or (worst case) is this just normal?

TIA for you help,
Ian

iffy50
Posts: 43
Joined: Sun Jan 23, 2011 2:45 pm
Location: Bonn, Germany

Re: IRIX 6.5.30 Awful Application Instability

Unread postby iffy50 » Fri Apr 22, 2011 3:42 am

Oh, one other thing that crossed my mind. I've now got 2 x 512Mb and 6 x 128Mb modules installed (all newer, small sized). I tried 4 x 256 large modules alongside the 2 x 512 in there and the machine wouldn't even boot. Could the mix of memory modules be part of the problem?

User avatar
guardian452
Posts: 2928
Joined: Tue Aug 21, 2007 10:12 pm
Contact:

Re: IRIX 6.5.30 Awful Application Instability

Unread postby guardian452 » Fri Apr 22, 2011 7:35 am

Try the memory sticks one pair at a time until you chase down the bad stick. Sounds like it is the 2 x 512 pair since the problems are following those. (i.e. remove the 512 sticks and see if that solves the problem)

iffy50
Posts: 43
Joined: Sun Jan 23, 2011 2:45 pm
Location: Bonn, Germany

Re: IRIX 6.5.30 Awful Application Instability

Unread postby iffy50 » Fri Apr 22, 2011 1:32 pm

OK, tried the memory and it doesn't make any difference. Still just as unstable. I think that I'll go for a rebuild....

Slightly more worryingly, I've noticed that with the DCD DVI connected, after about a half an hour of usage the screen flickers and then goes off. I haven't seen the same behavior when I use the 13w3. Looks like either a dry joint or something heat related.

Cheers,
Ian

User avatar
recondas
Moderator
Moderator
Posts: 5269
Joined: Sun Jun 06, 2004 5:55 pm
Location: NC - USA

Re: IRIX 6.5.30 Awful Application Instability

Unread postby recondas » Fri Apr 22, 2011 2:30 pm

iffy50 wrote:...my Octane(2) - Dual 300Mhx V12 DCD 1.75gb....when the monitor gets turned off for power saving, I can't wake it up again.....I've noticed that with the DCD DVI connected, after about a half an hour of usage the screen flickers and then goes off
Perhaps a long shot - but maybe your instability problems are power related. You didn't mention the power supply in your list of upgrades (or did you already have the second generation version?).
***********************************************************************
Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
***********************************************************************

iffy50
Posts: 43
Joined: Sun Jan 23, 2011 2:45 pm
Location: Bonn, Germany

Re: IRIX 6.5.30 Awful Application Instability

Unread postby iffy50 » Fri Apr 22, 2011 4:10 pm

Yup, it's got a Cherokee in there. Rebuild's in progress, so here's hoping that it'll do the job. Interestingly, I've got a basic server installed without 4dwm and it only sends video output to the dcd, not the 13w3 (foxed me for a bit, that one, I had the wrong connector in). but with the dcd and a cut down x11, the screens stayed happy for an hour or so. Could be good news, but I'm not celebrating quite yet.

Anyway, I'm doing the rest of the install now, so let's see what happens.

Interestingly, when you do a fresh 6.5.30 install and forget to open up the applications cd, then it will install. You just don't get any of the normal desktop. Somehow the dependancies will resolve. Live and learn...

Thanks for all your help,
Ian

User avatar
PymbleSoftware
Posts: 1887
Joined: Tue Jul 15, 2008 5:48 pm
Location: P.O. Box 121, Pymble, Sydney, NSW 2073, Australia.
Contact:

Re: IRIX 6.5.30 Awful Application Instability

Unread postby PymbleSoftware » Fri Apr 22, 2011 11:53 pm

It probably won't solve anything but if you happened to have the MIPS Pro compiler suite or happen to have the dbx debugger. Run the application under the debugger. Where it crashes might give you a hint for example if it crashes in malloc or new then look at the memory.

In a winterm try:

dbx firefox

Then post back the results. It could be anything, something simple like missing or corrupt LD_LIBRARY_PATH or corrupt libraries refusing to load, memory faults, something I could not even guess at..

R.
死の神はりんごだけ食べる

開いた括弧は必ず閉じる -- あるプログラマー

:Tezro: :Tezro: :Onyx2R: :Onyx2RE: :Onyx2: :O3x04R: :O3x0: :O200: :Octane: :Octane2: :O2: :O2: :Indigo2IMP: :PI: :PI: :1600SW: :1600SW: :Indy: :Indy: :Indy: :Indy: :Indy:
:hpserv: J5600, 2 x Mac, 3 x SUN, Alpha DS20E, Alpha 800 5/550, 3 x RS/6000, Amiga 4000 VideoToaster, Amiga4000 -030, 733MHz Sam440 AmigaOS 4.1 update 1.

Sold: :Indy: :Indy: :Indy: :Indigo: Tandem Himalaya S-Series Nonstop S72000 ServerNet.

@PymbleSoftware
Current Apps -> https://itunes.apple.com/au/artist/pymb ... d553990081
Cortex ---> http://www.facebook.com/pages/Cortex-th ... 11?sk=info
Minnie ---> http://www.facebook.com/pages/Minnie-th ... 02?sk=info
Github ---> https://github.com/pymblesoftware
Visit http://www.pymblesoftware.com
Search for "Pymble", "InstaElf", "CryWhy" or "Cricket Score Sheet" in the iPad App store or search for "Pymble" or "CryWhy" in the iPhone App store.

iffy50
Posts: 43
Joined: Sun Jan 23, 2011 2:45 pm
Location: Bonn, Germany

Re: IRIX 6.5.30 Awful Application Instability

Unread postby iffy50 » Sun Apr 24, 2011 12:55 pm

Right, all up and running with a fresh build and all seems to be much better. No crashes on anything so far, although I haven't done exactly exhaustive testing. However, I'm typing this from Seamonkey, and there's no way that I would have got that far before. If I get any problems again then I'll try the debugging.

I've still got an 'interesting challenge' around the V12 and DCD, but I'm going to stick that in a different post as it's not directly related to this subject.

Cheers and thanks to all of the people that replied,
Ian


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 1 guest