Search found 2694 matches

by dexter1
Sun Jan 14, 2018 5:41 am
Forum: IRIX and Software
Topic: ipfilterd udp
Replies: 12
Views: 234

Re: ipfilterd udp

Suppose you want to run nfs services from within your home network to the octane, did you perform an attempt of directly connecting the octane to the nfs server omitting the router? This way you can check three possible causes: - if Gigabit speeds are attainable - if ipfilter(d) causes havoc just be...
by dexter1
Tue Jan 02, 2018 3:19 pm
Forum: Everything Else
Topic: What pointless thing are you doing right now?
Replies: 335
Views: 20863

Re: What pointless thing are you doing right now?


Looks like you're on to a new way of catching bitcoins as they float through the ether. I like it!
by dexter1
Mon Jan 01, 2018 2:27 am
Forum: SGI: Hardware
Topic: SCSI2SD v6 vs Indy
Replies: 6
Views: 228

Re: SCSI2SD v6 vs Indy

See this tread: http://forums.nekochan.net/viewtopic.php?f=3&t=16731287&hilit=scsi2sd+cdrom Apparently the SCSI2SD v5 does not like to be paired with other devices on the SCSI chain, this may happen to the v6 as well. Since the Indy only has one controller, i'm afraid you're stuck with eithe...
by dexter1
Fri Dec 29, 2017 3:15 pm
Forum: IRIX and Software
Topic: IRIX remote install from macOS
Replies: 5
Views: 145

Re: IRIX remote install from macOS

Have never used a docker, may have to look at doing a simple debian install on a spare drive. Edit: ...or can I just fire up a VM Debian install and do it through that? Well a Debian install on a spare drive would be a bit overkill, but before you go that route, try a docker or a VM. I made the doc...
by dexter1
Fri Dec 29, 2017 1:31 pm
Forum: IRIX and Software
Topic: IRIX remote install from macOS
Replies: 5
Views: 145

Re: IRIX remote install from macOS

I'm not familiar with OSX, but isn't rshd on the list of supported services? You could try to enable that. If that solution doesn't fly, it may be possible to run a docker which has the required services set up. I have created such a docker based on debian on https://hub.docker.com/r/dexter1/irix-in...
by dexter1
Thu Dec 28, 2017 3:23 am
Forum: IRIX and Software
Topic: Cool (open source) software you would like to see ported...
Replies: 728
Views: 65132

Re: Cool (open source) software you would like to see ported...

Raion-Fox wrote:Anyone have a go with libarchive? Includes a BSD tar implementation that would be VERY nice to have.

This looks doable: uses cmake 2.8 and can enable/disable compression formats. So it's best to link against neko_libz/bzip2/lzma at the least.
by dexter1
Sat Nov 11, 2017 2:13 am
Forum: SGI: Development
Topic: libssh 0.7.1
Replies: 3
Views: 165

Re: libssh 0.7.1

Done. Have missed this library development. In what way does this augment openssh/ssl functionality? Or is the licensing different?
by dexter1
Sat Nov 11, 2017 2:09 am
Forum: SGI: Development
Topic: hydra 8.7-dev
Replies: 1
Views: 124

Re: hydra 8.7-dev

Done. I'm a bit out of the loop currently. Please poke me if there is more to be transferred
by dexter1
Sat Nov 04, 2017 4:23 pm
Forum: SGI: Discussion
Topic: How frequently you use your SGI (in 2017)?
Replies: 80
Views: 3335

Re: How frequently you use your SGI (in 2017)?

jirka wrote:The configuration is OK, I think. But I'm not able to compile the mpg123 for the IRIX 5.3 at the moment (and I am not able to find one which works on the R3k Indigo...).


From geektechnique.org :
mpg123-irix5.3-mips1-static.bin
(224.27 KiB) Downloaded 11 times

Which is the same binary from Marcus' old site ftp.mayn.de
by dexter1
Sat Nov 04, 2017 4:08 pm
Forum: IRIX and Software
Topic: IRIX in virtual machines
Replies: 4
Views: 394

Re: IRIX in virtual machines

If you want to try and make an emulator start with something easy like an Indy or Indigo1 Correct, and there are currently efforts underway to emulate an Indy, see http://forums.nekochan.net/viewtopic.php?f=30&t=16730487 When successful, this should be able to run IRIX emulated: In that thread ...
by dexter1
Tue Oct 24, 2017 6:42 am
Forum: IRIX and Software
Topic: Can't start neko_sshd, missing ssh_host_ecdsa_key!?!?
Replies: 2
Views: 176

Re: Can't start neko_sshd, missing ssh_host_ecdsa_key!?!?

Use the command 'which ssh-keygen' to identify the binary. Alternatively, try Canavan's Beta directory at http://www.nekochan.net/nekoware/index.php?path=beta%2Fcanavan/ for up-to-date ssh and ssl binaries or get mine from http://www.nekochan.net/nekoware/index.php?path=dual-mips3-mips4/ for both mi...
by dexter1
Sun Oct 22, 2017 2:53 pm
Forum: SGI: hinv
Topic: "dubious" - was Tezro: now Onyx 4 - 4x700 with V12/DCD/DM3
Replies: 8
Views: 632

Re: "dubious" - was Tezro: now Onyx 4 - 4x700 with V12/DCD/DM3

I don't have the knowledge to dive into all the stuff you have posted so far, but i just want to give you a word of appreciation for all the experience and information you shared on various posts concerning these tezro/onyx4 systems. Thank you, it is very appreciated.
by dexter1
Sun Oct 22, 2017 11:31 am
Forum: SGI: Development
Topic: Archiver 0.1 - IRIX/IMD GUI for tar.
Replies: 47
Views: 1318

Re: Archiver 0.1 - IRIX/IMD GUI for tar.

[It's a let's encrypt certificate (I'm cheap) and that might be the issue? Could be, but i can curl https://helloworld.letsencrypt.org/ but not the mercurial repo via https. I don't think the certificate is invalid, it's probably mercurial. If i supply '--insecure' to the https url, it works: hg cl...
by dexter1
Sun Oct 22, 2017 10:20 am
Forum: SGI: Development
Topic: Archiver 0.1 - IRIX/IMD GUI for tar.
Replies: 47
Views: 1318

Re: Archiver 0.1 - IRIX/IMD GUI for tar.

I don't have any myself, but I understand the Teac drives that SGI used have a plastic cog that tends to break/fall off. Yes, except they are Toshiba's, see http://forums.nekochan.net/viewtopic.php?f=3&t=16727779#p7360973 UPDATE: Public URL: https://mercurial.shangtai.net/repo/Archiver hg clone...
by dexter1
Mon Oct 16, 2017 2:39 am
Forum: SGI: Development
Topic: rdesktop 1.8.3
Replies: 18
Views: 971

Re: rdesktop 1.8.3

I downloaded the package from the above post and put it in /beta

Is there still a need for the old 1.7.1 version? If not, i will put that in /obsolete

Go to advanced search