Search found 275 matches

by competentcompton
Fri Sep 25, 2015 5:42 am
Forum: IRIX and Software
Topic: 6.5.30 troubles with inst and swmgr
Replies: 28
Views: 1131

Re: 6.5.30 troubles with inst and swmgr

Hi, thanks for the great info. I will try that and see how it works. I was able to work around by copying just the scsl stuff that I was after to a single directory on the hard disk (rather than let it hack on the /CDROM/dist) If anyone was interested I had a bit of a DUH moment with my scsl problem...
by competentcompton
Tue Sep 22, 2015 11:26 pm
Forum: IRIX and Software
Topic: 6.5.30 troubles with inst and swmgr
Replies: 28
Views: 1131

Re: 6.5.30 troubles with inst and swmgr

I have no idea what that means or how it is in anyway relevant I was referring to the fact that it was a single install from a complete 6.5.30 set of CDs. Not for example like other systems where I used a 6.5.17 install set and later performed a maintenance upgrade to take it to 6.5.22m As for the a...
by competentcompton
Tue Sep 22, 2015 7:42 pm
Forum: IRIX and Software
Topic: 6.5.30 troubles with inst and swmgr
Replies: 28
Views: 1131

Re: 6.5.30 troubles with inst and swmgr

A few more details. Mine is a Tezro and it has a clean 6.5.30 install from CD not an upgrade. The CDs are version 6.5.30. I was trying to reinstall scsl due to the SEGV and if that didn't fix the problem then I was going to install 1.14.1.1 which works on my octane with 6.5.22m I didn't recall that ...
by competentcompton
Tue Sep 22, 2015 6:10 pm
Forum: IRIX and Software
Topic: 6.5.30 troubles with inst and swmgr
Replies: 28
Views: 1131

Re: swmgr seems to hang

yes, just switching to Manage Installed Software does list most things, but like I mentioned not scsl, I am not sure what else is not listed. It has now been running for 3 hours with no progress stuck in sys cpu usage. Really wish I could see wht it was up to. Is there anyway to sanity check or recr...
by competentcompton
Tue Sep 22, 2015 3:41 pm
Forum: IRIX and Software
Topic: Origin terminal
Replies: 12
Views: 751

Re: Origin terminal

If you use VcXsrv than you can remote login using X from your old windows XP like I do - works mostly, but does not do well storing sessio info between logins I have ever used VcXsrv in anything other than XP so not sure if newer version work okay but I suspect they should. chose and XDMCP session a...
by competentcompton
Tue Sep 22, 2015 3:37 pm
Forum: IRIX and Software
Topic: 6.5.30 troubles with inst and swmgr
Replies: 28
Views: 1131

Re: swmgr seems to hang

hmm, thanks guys tried panes, nothing output ... Also copied the disk and invoked with swmgr -f I am selecting "Customize Installation" - think I forgot to mention that in my original post it is as I type still sat looking at me in the initialize phase and using 99% cpu etc. One other thin...
by competentcompton
Tue Sep 22, 2015 1:56 pm
Forum: IRIX and Software
Topic: 6.5.30 troubles with inst and swmgr
Replies: 28
Views: 1131

swmgr seems to hang

Hi, Trying to use swmgr to read my Irix 6.5.30 apps CD. The CD mounts fine and I can read the contents so I don't think that is the problem. However swmgr just sits and consumes almost 99% cpu mostly in sys (red bar on gr_osview - not very scientific I know) After almost an hour I killed it, but I h...
by competentcompton
Thu Apr 17, 2014 1:57 am
Forum: SGI: Development
Topic: strerror_r
Replies: 4
Views: 403

Re: strerror_r

Hi, thanks for the reply. I did a similar search and couldn't find anything related other than goserror which is related to sproc and is specifically stated to not be compatible with pthreads. I was just wondering as to whether there was an equivalent under another name in irix and thought I would c...
by competentcompton
Tue Apr 15, 2014 4:08 pm
Forum: SGI: Development
Topic: strerror_r
Replies: 4
Views: 403

strerror_r

Hi,

does anyone know if irix has a strerror_r() implemented.

Ran into with a recent compile and want to check before I code one?

Cheers
by competentcompton
Fri Apr 11, 2014 2:01 pm
Forum: SGI: Development
Topic: std::getline() problem
Replies: 5
Views: 403

Re: std::getline() problem

That was spot on.

I must have just installed all the patches etc. at the same time and so it reported 7.4.4m but when I opened the .tardist all the patches were marked as ne.

Installing these fixed the problem.

thanks for catching that - I wasted some time but not as much as I could have

Cheers
by competentcompton
Fri Apr 11, 2014 4:35 am
Forum: SGI: Development
Topic: std::getline() problem
Replies: 5
Views: 403

Re: std::getline() problem

how do I get a more accurate picture of my system?
by competentcompton
Fri Apr 11, 2014 4:34 am
Forum: SGI: Development
Topic: std::getline() problem
Replies: 5
Views: 403

Re: std::getline() problem

I am using 6.5.30m and 7.4.4 also - no idea why it does not work then?

Cheers
by competentcompton
Fri Apr 11, 2014 2:42 am
Forum: SGI: Development
Topic: std::getline() problem
Replies: 5
Views: 403

std::getline() problem

Hi, having problems with error from the following code snippet #include <string> #include <iostream> using namespace std; int main(int,char*argv[]) { basic_string<wchar_t> ws_t; basic_istream<wchar_t>* is; is=&wcin; if(std::getline(*is,ws_t,L'\n')) { wcout << "INPUT : " << ws_t; } retu...
by competentcompton
Thu Mar 06, 2014 2:49 am
Forum: SGI: Development
Topic: trying to use round() with CC -c99 ??
Replies: 3
Views: 412

Re: trying to use round() with CC -c99 ??

hmm, thanks for your input that is interesting. So if I write a c program that uses round() when I compile with c99, or any other option it still get identifier "round" is undefined. Additionally C++ code using #include <cstlib> to use atoi and it fails with undefined. Tried the option -LA...
by competentcompton
Wed Mar 05, 2014 2:13 am
Forum: SGI: Development
Topic: trying to use round() with CC -c99 ??
Replies: 3
Views: 412

trying to use round() with CC -c99 ??

Hi, I am trying to figure out how to use the round() function from CC with a -c99 option any help would be appreciated. I am sure that I have got this backwards but when I try to force is I get a bunch of __restrict errors. When I add <internal/sgimacros.h> nothing much changes I am sure that the fi...

Go to advanced search